# Unable to push to the Nest

**URL:** <https://discourse.pijul.org/t/unable-to-push-to-the-nest/1214>\
**Category:** Uncategorized\
**Created:** [August 23, 2024, 6:58am UTC](https://discourse.pijul.org/t/unable-to-push-to-the-nest/1214 "2024-08-23T06:58:18Z")\
**Posts on this page:** 11\
**Page:** 1

<div class="post-metadata">

**Author:** ![apraga](https://avatars.discourse-cdn.com/v4/letter/a/9de053/32.png) [@apraga](https://discourse.pijul.org/u/apraga)\
**Post date:** [August 23, 2024, 6:58am UTC](https://discourse.pijul.org/t/unable-to-push-to-the-nest/1214/1 "2024-08-23T06:58:18Z")

</div>

Hi,

I’ve uploaded my public SSH key to the nest (RSA) but pushing asks for a password. Using the SSH passphrase is not recognized for the first. Using the Nest password for the second does not work either.

❯ pijul push [apraga@ssh.pijul.com](mailto:apraga@ssh.pijul.com):apraga/org  
✔ Password for encrypted private key · \*\*\*\*\*\*\*\*  
Warning: Unable to automatically authenticate with server. Please make sure your SSH keys have been uploaded to the Nest.  
For more information, please visit [Uploading public keys - The Pijul manual](https://pijul.org/manual/the_nest/public_keys.html#ssh-public-keys)  
✔ Password for [apraga@ssh.pijul.com](mailto:apraga@ssh.pijul.com) · \*\*\*\*\*\*\*\*

Is it another SSH key that should be uploaded ?  
The issue is reproducible for pijul installed with nix or cargo.

Thanks,

---

<div class="post-metadata">

**Author:** ![tankf33der](https://yyz1.discourse-cdn.com/flex031/user_avatar/discourse.pijul.org/tankf33der/32/289_2.png) [@tankf33der](https://discourse.pijul.org/u/tankf33der)\
**Post date:** [August 23, 2024, 7:26am UTC](https://discourse.pijul.org/t/unable-to-push-to-the-nest/1214/2 "2024-08-23T07:26:23Z")

</div>

I have already seen this problem. You will have to wait for a hotfix. The system is unstable for now.

---

<div class="post-metadata">

**Author:** ![apraga](https://avatars.discourse-cdn.com/v4/letter/a/9de053/32.png) [@apraga](https://discourse.pijul.org/u/apraga)\
**Post date:** [August 23, 2024, 7:41am UTC](https://discourse.pijul.org/t/unable-to-push-to-the-nest/1214/3 "2024-08-23T07:41:17Z")

</div>

Thank for the quick reply. it’s appreciated.

---

<div class="post-metadata">

**Author:** ![apraga](https://avatars.discourse-cdn.com/v4/letter/a/9de053/32.png) [@apraga](https://discourse.pijul.org/u/apraga)\
**Post date:** [August 24, 2024, 12:05pm UTC](https://discourse.pijul.org/t/unable-to-push-to-the-nest/1214/4 "2024-08-24T12:05:50Z")

</div>

Edit: I’ve recreated the identity as it seems default parameters are not set (during identity creation). I’ve also forced key encryption to have a password to type (assuming the password asked is not the SSH password !).

Now there is a long delay after entering the password but the error is still there.

Log

```auto
[2024-08-24T12:02:47Z 
✔ Password for encrypted private key · ********
Warning: Unable to automatically authenticate with server. Please make sure your SSH keys have been uploaded to the Nest.
For more information, please visit https://pijul.org/manual/the_nest/public_keys.html#ssh-public-keys
[2024-08-24T12:11:45Z ERROR pijul] Error: "Not authenticated. Please check your credentials and try again."
Error: Not authenticated. Please check your credentials and try again.
DEBUG pijul_repository] "/home/alex/org/.pijul"
[2024-08-24T12:02:47Z DEBUG pijul_repository] max_files = 32
[2024-08-24T12:02:47Z DEBUG pijul::commands::pushpull] Config { default_remote: Some("https://nest.pijul.com/apraga/org"), extra_dependencies: [], remotes: [], hooks: Hooks { record: [] }, unrecord_changes: None, reset_overwrites_changes: None, colors: None, pager: None }
[2024-08-24T12:02:47Z DEBUG pijul::commands::pushpull] remote_channel = "main" None
[2024-08-24T12:02:47Z DEBUG pijul_remote::ssh] ssh_remote: Captures({0: 0..31/"apraga@ssh.pijul.com:apraga/org", 1: None, 2: 0..7/"apraga@", 3/"user": 0..6/"apraga", 4: 7..20/"ssh.pijul.com", 5/"host": 7..20/"ssh.pijul.com", 6: None, 7: None, 8: 7..20/"ssh.pijul.com", 9: 20..31/":apraga/org", 10: None, 11/"port": None, 12/"path0": None, 13: None, 14: 20..31/":apraga/org", 15/"path1": 21..31/"apraga/org", 16/"path2": None, 17: None})
[2024-08-24T12:02:47Z DEBUG pijul_remote] unknown_remote, ssh = Remote { path: "apraga/org", config: Config { user: "apraga", host_name: "ssh.pijul.com", port: 22, identity_file: None, proxy_command: None, add_keys_to_agent: No } }
[2024-08-24T12:02:47Z DEBUG pijul_remote::ssh] addr = "ssh.pijul.com" port = 22
[2024-08-24T12:02:47Z DEBUG pijul_remote::ssh] identities = []
[2024-08-24T12:02:47Z DEBUG pijul_config] s = [91, 97, 117, 116, 104, 111, 114, 93, 10, 110, 97, 109, 101, 32, 61, 32, 34, 97, 112, 114, 97, 103, 97, 34, 10, 102, 117, 108, 108, 95, 110, 97, 109, 101, 32, 61, 32, 34, 65, 108, 101, 120, 105, 115, 32, 80, 114, 97, 103, 97, 34, 10, 101, 109, 97, 105, 108, 32, 61, 32, 34, 97, 108, 101, 120, 105, 115, 46, 112, 114, 97, 103, 97, 64, 112, 114, 111, 116, 111, 110, 46, 109, 101, 34, 10]
✔ Password for encrypted private key · ********
Warning: Unable to automatically authenticate with server. Please make sure your SSH keys have been uploaded to the Nest.
For more information, please visit https://pijul.org/manual/the_nest/public_keys.html#ssh-public-keys
[2024-08-24T12:11:45Z ERROR pijul] Error: "Not authenticated. Please check your credentials and try again."
Error: Not authenticated. Please check your credentials and try again.

```

Also, I have the same issue with a repo on a private SSH (if that helps).

---

<div class="post-metadata">

**Author:** ![apraga](https://avatars.discourse-cdn.com/v4/letter/a/9de053/32.png) [@apraga](https://discourse.pijul.org/u/apraga)\
**Post date:** [August 25, 2024, 10:10am UTC](https://discourse.pijul.org/t/unable-to-push-to-the-nest/1214/5 "2024-08-25T10:10:56Z")

</div>

Update : re-creating the key without encryption does not ask for a password (after restarting ssh-agent) but it fails after a long delay

```auto
$ pijul push
[2024-08-25T09:58:07Z DEBUG pijul_repository] "/home/alex/org/.pijul"
[2024-08-25T09:58:07Z DEBUG pijul_repository] max_files = 32
[2024-08-25T09:58:07Z DEBUG pijul::commands::pushpull] Config { default_remote: Some("apraga@ssh.pijul.com:apraga/org"), extra_dependencies: [], remotes: [], hooks: Hooks { record: [] }, unrecord_changes: None, reset_overwrites_changes: None, colors: None, pager: None }
[2024-08-25T09:58:07Z DEBUG pijul::commands::pushpull] remote_channel = "main" None
[2024-08-25T09:58:07Z DEBUG pijul_remote::ssh] ssh_remote: Captures({0: 0..31/"apraga@ssh.pijul.com:apraga/org", 1: None, 2: 0..7/"apraga@", 3/"user": 0..6/"apraga", 4: 7..20/"ssh.pijul.com", 5/"host": 7..20/"ssh.pijul.com", 6: None, 7: None, 8: 7..20/"ssh.pijul.com", 9: 20..31/":apraga/org", 10: None, 11/"port": None, 12/"path0": None, 13: None, 14: 20..31/":apraga/org", 15/"path1": 21..31/"apraga/org", 16/"path2": None, 17: None})
[2024-08-25T09:58:07Z DEBUG pijul_remote] unknown_remote, ssh = Remote { path: "apraga/org", config: Config { user: "apraga", host_name: "ssh.pijul.com", port: 22, identity_file: None, proxy_command: None, add_keys_to_agent: No } }
[2024-08-25T09:58:07Z DEBUG pijul_remote::ssh] addr = "ssh.pijul.com" port = 22
[2024-08-25T09:58:07Z DEBUG pijul_remote::ssh] identities = [Ed25519(PublicKey { key: [221, 169, 101, 208, 19, 169, 25, 95, 156, 133, 220, 79, 59, 190, 251, 72, 140, 175, 239, 95, 93, 197, 162, 86, 71, 12, 81, 220, 125, 17, 56, 41] })]
[2024-08-25T09:58:07Z DEBUG pijul_remote::ssh] Trying key Ed25519(PublicKey { key: [221, 169, 101, 208, 19, 169, 25, 95, 156, 133, 220, 79, 59, 190, 251, 72, 140, 175, 239, 95, 93, 197, 162, 86, 71, 12, 81, 220, 125, 17, 56, 41] })
[2024-08-25T09:58:07Z DEBUG pijul_remote::ssh] fingerprint = "XXXXXXXXX"
[2024-08-25T09:58:07Z DEBUG pijul_remote::ssh] authenticate future
Warning: Unable to automatically authenticate with server. Please make sure your SSH keys have been uploaded to the Nest.
For more information, please visit https://pijul.org/manual/the_nest/public_keys.html#ssh-public-keys
[2024-08-25T10:08:08Z ERROR pijul] Error: "Not authenticated. Please check your credentials and try again."
Error: Not authenticated. Please check your credentials and try again.

```

---

<div class="post-metadata">

**Author:** ![apraga](https://avatars.discourse-cdn.com/v4/letter/a/9de053/32.png) [@apraga](https://discourse.pijul.org/u/apraga)\
**Post date:** [September 1, 2024, 12:38pm UTC](https://discourse.pijul.org/t/unable-to-push-to-the-nest/1214/6 "2024-09-01T12:38:35Z")

</div>

Pushing to [ssh.pijul.org](http://ssh.pijul.org) or [nest.pijul.org](http://nest.pijul.org) gives the same error.

---

<div class="post-metadata">

**Author:** ![o01eg](https://yyz1.discourse-cdn.com/flex031/user_avatar/discourse.pijul.org/o01eg/32/96_2.png) [@o01eg](https://discourse.pijul.org/u/o01eg)\
**Post date:** [February 2, 2025, 5:15pm UTC](https://discourse.pijul.org/t/unable-to-push-to-the-nest/1214/7 "2025-02-02T17:15:10Z")

</div>

This error still isn’t solved.

---

<div class="post-metadata">

**Author:** ![tankf33der](https://yyz1.discourse-cdn.com/flex031/user_avatar/discourse.pijul.org/tankf33der/32/289_2.png) [@tankf33der](https://discourse.pijul.org/u/tankf33der)\
**Post date:** [February 4, 2025, 2:42pm UTC](https://discourse.pijul.org/t/unable-to-push-to-the-nest/1214/8 "2025-02-04T14:42:16Z")

</div>

hi all,

After some experiments i’ve got working pijul.  
Now i can clone and push over ssh to nest as a hotfix.

If this is still relevant, let me know, and I will explain what I have done.

---

<div class="post-metadata">

**Author:** ![o01eg](https://yyz1.discourse-cdn.com/flex031/user_avatar/discourse.pijul.org/o01eg/32/96_2.png) [@o01eg](https://discourse.pijul.org/u/o01eg)\
**Post date:** [February 4, 2025, 5:47pm UTC](https://discourse.pijul.org/t/unable-to-push-to-the-nest/1214/9 "2025-02-04T17:47:05Z")

</div>

Yes, I suppose it’s very relevant.

---

<div class="post-metadata">

**Author:** ![tankf33der](https://yyz1.discourse-cdn.com/flex031/user_avatar/discourse.pijul.org/tankf33der/32/289_2.png) [@tankf33der](https://discourse.pijul.org/u/tankf33der)\
**Post date:** [February 4, 2025, 8:24pm UTC](https://discourse.pijul.org/t/unable-to-push-to-the-nest/1214/10 "2025-02-04T20:24:46Z")

</div>

The server-side has moved forward, while pijul remains stagnant.  
This can be easily fixed with a dirty hack at your own risk.

```auto
cd pijul
pijul remote
  I5GEGWCQIJKTINCFGJEEIVZXKU: https://nest.pijul.com/pijul/pijul
pijul reset --force
cargo update
cd pijul-remote
vi Cargo.toml
# change thrussh = "0.34" to "0.35.6"
cargo update
cd ..
cargo build --release
cd
pijul clone tankf33der@nest.pijul.com:tankf33der/picolisp
# cloned
cd picolisp
# change something
pijul rec -am"."
pijul push -a
# pushed

```

Please try and report.

p.s. I would like to point out that pushing via HTTPS was also possible before, but it is broken as well.

---

<div class="post-metadata">

**Author:** ![o01eg](https://yyz1.discourse-cdn.com/flex031/user_avatar/discourse.pijul.org/o01eg/32/96_2.png) [@o01eg](https://discourse.pijul.org/u/o01eg)\
**Post date:** [February 6, 2025, 4:48pm UTC](https://discourse.pijul.org/t/unable-to-push-to-the-nest/1214/11 "2025-02-06T16:48:01Z")

</div>

Thanks, it works. I opened discussion about it [pijul/pijul - Discussion #963 - Thrussh should be updated to fix push command for nest](https://nest.pijul.com/pijul/pijul/discussions/963)
