Suggestion: change executable name to `pj`



  1. It’s easier to remember
  2. It’s very ergonomic to type (hand moves smoothly through p-j-space)
  3. Adopting short but unique executable names is common practice across Rust crates (rg, fd, sk, …)
  4. Version control should be ergonomic by default (git does it right)


While you wait for an official reply, consider adding a shell alias so that you can get used to typing what you desire.

I’m curious what your fourth reason means. I would think that a full word, pijul, would be easier for accessibility software, like a screen reader, to communicate than two consecutive consonants. Likely, I’ve misunderstood what accessible means in this context, even with the hint about git.


Oh that’s a great idea. No offence but I stand little chance of spelling / remembering pijul right.

pj is much easier to remember and faster to type than git :slight_smile:
(and easier to recommend to others aurally - they won’t get pj wrong when they search for pj version control system)


Oh, sorry for my terrible English and thank you for suggestion.

Behind “accessible” I was mean “such that provides direct access to features” e.g. git is simple to type and because of that it makes add, commit, push features easier to access.

There always are situations when you want to work on someone’s else machine or provide terminal demonstration. In context of version control typing of long commands could be a real pain.


Well, that depends on your keyboard layout :smile: As a Dvorak user, the p and j are not placed that conveniently.

But it would still be faster to type than pijul (which on Dvorak is almost all on the left hand).

Personally, I use the alias anu which is the Portuguese name for the same bird (but I also get why that is not a desired name for a binary :stuck_out_tongue:).


I wouldn’t change the name of the executable, just add a shell alias if you want a different name. But i would like to be able to define aliases for pijul commands like i do for git: g s (g: shell alias for git; s: git alias for status).