Pijul

Unable to install on Arch Linux

Hello! I was hoping to use Pijul to track my Advent of Code 2020 progress, but I wasn’t able to complete the cargo install instructions on the website.

After installing the relevant packages and running cargo install pijul --version 1.0.0-alpha.17, I get the following errors:

error[E0433]: failed to resolve: could not find `v3` in `change`
  --> /home/cam/.cargo/registry/src/github.com-1ecc6299db9ec823/pijul-1.0.0-alpha.17/src/commands/upgrade.rs:34:52
   |
34 |                     let change = libpijul::change::v3::LocalChange3::deserialize(
   |                                                    ^^ could not find `v3` in `change`

error[E0658]: use of unstable library feature 'path_buf_capacity'
  --> /home/cam/.cargo/registry/src/github.com-1ecc6299db9ec823/pijul-1.0.0-alpha.17/src/commands/archive.rs:65:26
   |
65 |                     path.clear();
   |                          ^^^^^
   |
   = note: see issue #58234 <https://github.com/rust-lang/rust/issues/58234> for more information

error: aborting due to 2 previous errors

The second suggests that I need to switch to a nightly compiler (which is strange; I thought I was already on one), but the first I have no idea how to resolve. I can provide any other system details necessary, if they’d be helpful.

Welcome here! I’m not sure how semantic versioning is supposed to work in alpha, but you should really try and get the latest version. It is 1.0.0-alpha.21, as of today.

Thanks! I was following the instructions on this page, which, at the time of writing, says 1.0.0-alpha.17; it’d probably be useful to keep this up to date.

EDIT: After changing to alpha.21, it indeed fixes the libpijul issue. However, it still gives the error about unstable library features, despite my rustup telling me that I am indeed on nightly.

You shouldn’t need nightly at all. The latest stable should work, maybe you should rustup update?

I had the same result yesterday (actually, 3 errors).
But using alpha.21, I now have a working pijul command. I’m on Ubuntu Studio, though.

Thanks for the assistance! A rustup update indeed solved the problem.

Probably related? Arch. For some reason it says 1.0.19 despite rustup update, followed by cargo install:

falis@garuda ~/D/I/pijul> cargo install pijul --version 1.0.0-alpha.21

error: no override and no default toolchain set

Then:

falis@garuda ~/D/I/pijul [1]> pijul --version
pijul 1.0.0-alpha.19
falis@garuda ~/D/I/pijul> cd xmonad
falis@garuda ~/D/I/p/xmonad> pijul list .
Error: No such file or directory (os error 2)

All of the commands I’ve tried give the same error.

I’m feeling a bit dense today, so I won’t be surprised if this is something that should be obvious.

The AUR package should be installable:

Please let me know if you have any problems with it.