Pijul

Building Alpha 22 On Windows 10

In trying to build alpha 22 on Windows 10, I receive this error:

LINK : fatal error LNK1181: cannot open input file 'zstd.lib'

I have Visual Studio 2019 installed. Can anyone point me in the direction of information on how to resolve this issue? A web search turned up no useful information.

Thanks in advance.

Did you install zstd with vcpkg?

Hi, I’m running into the same error building alpha 22 on Windows 10.

I installed vcpkg and libsodium, xxhash and zstd with it.

> .\vcpkg list
libsodium:x86-windows                              1.0.18-2         A modern and easy-to-use crypto library
xxhash:x86-windows                                 0.8.0#1          Extremely fast hash algorithm
zstd:x86-windows                                   1.4.5#1          Zstandard - Fast real-time compression algorithm

I do only have VS Build Tools 2019 installed, not full VS. I ran vcpkg integrate install and set VCPKG_ROOT as well.

Full list of steps taken to install:

> scoop install openssl
# Set OPENSSL_DIR environment variable
> git clone https://github.com/microsoft/vcpkg
> cd vcpkg
> .\bootstrap-vcpkg.bat
> .\vcpkg install libsodium xxhash zstd
> .\vcpkg integrate install
# Set VCPKG_ROOT environment variable
> cargo install pijul --version 1.0.0-alpha.22

When I last tried, I might have moved zstd.lib (installed with vcpkg) to the current directory. Also, I was compiling from the repository, but I don’t know if that changes anything.