"pijul changes" printing raw escape codes in Pijul 0.8.0


#1

First off, sorry if this isn’t the right place for bug reports. I tried to sign up for Nest, but the “Sign In With Google” and “Sign In With Github” buttons both just redirect me right back to the sign up page, and I didn’t feel like managing another set of credentials.

When I run pijul changes on a repository, I see the raw escape codes rather than color:

ESC[1mHash:ESC(BESC[m AcwsFw0yC5Q3VcrQq53svMEG8pmUMdAqqdb6VyJqie-fA11SfzBvpOAyO6OsMlv37MfX_NNfk98yOtxmPmQBqG8
ESC[1mInternal id:ESC(BESC[m zCwXDTILlDc
ESC[1mAuthors:ESC(BESC[m ["Pierre-Étienne Meunier <pe@pijul.org>"]
ESC[1mTimestamp:ESC(BESC[m 2017-09-15 14:40:20.909284607 UTC

    libpijul 0.8.1

I believe this is happening because pijul is piping output through more (which is surprising, most other applications use less even though I don’t actually have PAGER set). If I run PAGER=cat pijul changes, I see the expected result, with the headings in bold.

If using a pager, pijul should probably default to using something like less -FR or less -EFR rather than more, and if it’s using more, it should probably output without control characters.

I am running Mac OS X 10.12.6, where more is actually less running in more compatible mode. Oh, and for the Nest problem, I’m running Firefox 55.0.3.


#2

Hmm, the less -E and less -F options don’t seem to work correctly for me, causing nothing to be output if I have less than one screenful. Oh, well, at least -R should be used, or no control characters if piping through less.

Another option for formatting through a pager is the control characters that nroff/man use, which less and more interpret by default and convert into the appropriate terminal escape sequences. These are backspaces between a letter and an underscore to indicate that the letter should be underlined, and backspaces between two of the same letter to indicate that it should be in bold.


#3

Hi! Thanks for reporting, and sorry that you couldn’t use the Nest. What’s your github/gmail username? If they’re already taken, you can’t connect. This is certainly not great, and will change in the future.


#4

It had never even gotten to the point of redirecting me to GitHub or Google.

I just tried again and it works from the front page, but earlier I had wound up at https://nest.pijul.com/signup where the buttons just redirect right back to that page.


#5

Thanks for reporting!

In pijul 0.8, there have been several changes affecting pijul diff and macOS is definitely not the most tested platform for pijul as far as I can tell.

Pijul relies on the pager crate for the PAGER, and we let the crate chooses the pager (and it chooses the content of PAGER if it exists). We should probably changed that based on your experience

PS: As for myself, I cannot log in the Nest right now using a regular account. Don’t know if that helps.