Pijul

New release: 1.0.0-alpha.3 (and Nest repository reboot)

I’ve had to reset the history once again, because the recent change in the format introduced subtle changes in the algorithm, which I’m hoping I’ve solved today, mostly by simplifying stuff.

Is this the last time? I don’t know, I’ve written new tests to test for the recent changes, but I’ll try to go through the code of libpijul again and check if everything is alright.

5 Likes

Looks like record by this version made with repository created in previous version fully recreates files.

Authorisation in Nest and registration new account with email are broken. Only via Github works :frowning:

What do you mean, broken? What happens when you try to create an account?

Steps to reproduce:

  1. https://nest.pijul.com
  2. Register with email (left side of page)
  3. Follow link received via email
  4. Try to login (after submit you’r redirected to same page and not logged in)
  5. Try to login…
  6. Try to login… :smiley:

I just investigated this and found the bug. It should work now (meaning the link you receive should actually log you in).

That link finally works, but I still can’t log-in normally.

Those identicons are cool as hell, by the way. Do you use a lib for those?

1 Like

I just recorded a new change to one of my repos and the patch recorded it as deleting every file (so now the repo is empty).
This happened after just upgrading to 1.0.0-alpha.3

Additionally, you never said anything about needing to run the pijul upgrade command on local repositories, so I did it anyways, and it gave an error.

pijul upgrade was supposed to upgrade repositories to the new change format, but it doesn’t quite work, because the previous change format was missing important information.

No, I wrote that, but I can release the code if you want. Thanks!

3 Likes

Yes, please.

Thanks. Now it works.
I have found new one:

Account doesn’t deleted

  1. Create new account with Github
  2. Delete the account
  3. Create new account with Github again
  4. Err: Internal server error (this)

Also,

  1. Create new account with Github
  2. Delete the account
  3. Create new account with email and same nickname
  4. Err: Login already taken

So, I cannot create new account with same nickname because old still exists.


Also I can log in to deleted account with login-link from “restore forgotten password” email.
And I please you to un-mark (un-delete) my account, pmeunier.

I see. The Nest tries to comply with Europe’s GDPR, allowing you to delete your personal data, but keeping your public production on the site alive.

A possible solution would be to change the login to “fzzr - deleted”.

1 Like

Done. Thanks. Also now I cannot link github-account previously linked to that semi-deleted old account.