Nest.pijul.com doesn't complete login


#1

Greetings,

I tried logging into nest.pijul.com and the signin doesn’t complete.

kr/sjm


#2

So, just so you know, the Nest just underwent a massive reorganisation of its codebase.

As part of that task, I’ve implemented many security features that were missing before, to try and move to a more “production-like” kind of service.

I’ve noticed that your repository has disappeared, and I’d like to know more about it.

First, can you try to push your changes again?

Also, when did you try to log in exactly?


#3

Great to hear on the new reorganization!

I tried pushing changes again, using my recently generated id_ed25519.pub key and got this error:
error: SSH: No more authentication methods available

I must have pushed my changes shortly after 2017-09-01 08:15:17.089863316 UTC

my patch is AXmk0DWtjTZZU27Y0ZImsmsqEvHi32BViyiACf4H88sQCR4JC1537IHdyB8bX7fD88aiheag343nzVJvRJ1fWUk


#4

Can you paste your public key here?


#5

ssh-ed25519 AAAAC3NzaC1lZDI1NTE5AAAAIGs8t5esHTzc9vPRLHhkkmjhhFHWqFxMXRO2Dm66njFc stewart@rivergod


#6

Alright, I’m sorry about that. Can you try again and tell me when you’re done?


#7

ah okay well the first patch (cli arguments that allow { mkRustCrate, fetchzip}: and the top level indirection i.e. capnp = capnp_0_8_11 is done. (except the generated { mkRustCrate fetchzip} has an error (missing ,)). That needs another patch.

I still have the above patch ready to push as soon as I can login again.

I’m looking into the build_dependencies issue of nix-rust.


#8

What’s the problem with logging in?
Also, can you try to push your patches again and tell me when you’re done?


#9

logging in just does nothing. I insert my credentials and click login and nothing happens.
I’ve tried logging into nest via my github account again nothing happens.

$ RUST_BACKTRACE=1 pijul push sjmackenzie@nest.pijul.com:nix-rust
Hash: AYznG-9HZsJDiJoi59PChUD-e6Y94meOhi5VQT28AUB2COkyrU9AfZOqk1M4UD1-fou58sBt6WPgjeiW4eRfHT4
Internal id: jOcb70dmwkM
Authors: ["pmeunier <pe@pijul.org>"]
Timestamp: 2017-04-08 18:37:05.821191450 UTC

    Generating nix expressions from Cargo.lock files

Shall I push this patch? [ynkad] a
thread 'main' panicked at 'called `Result::unwrap()` on an `Err` value: Error(Disconnect)', src/libcore/result.rs:859
stack backtrace:
   0: std::sys::imp::backtrace::tracing::imp::unwind_backtrace
   1: std::sys_common::backtrace::_print
   2: std::panicking::default_hook::{{closure}}
   3: std::panicking::default_hook
   4: std::panicking::rust_panic_with_hook
   5: std::panicking::begin_panic
   6: std::panicking::begin_panic_fmt
   7: rust_begin_unwind
   8: core::panicking::panic_fmt
   9: core::result::unwrap_failed
  10: pijul::commands::remote::Session::push
  11: pijul::main
  12: std::panicking::try::do_call
  13: __rust_maybe_catch_panic
  14: std::rt::lang_start
  15: __libc_start_main
  16: _start

#10

Ok. My records here tell me that you don’t have a password, because you always logged in using github (although this might be an error on my side).

About SSH, I know what happened, and it should be fixed within 10 minutes.


#11

Ok, SSH push should be fixed, you can try again. Sorry about that.


#12

perfect, it went through: https://nest.pijul.com/sjmackenzie/nix-rust though the logging in still fails :slight_smile:


#13

Cool. About the logging in, again, you don’t have a password set. Do you mean the login with github fails?

If so, I’d like to know what browser you’re using.


#14

I tried both (register a direct associated account with nest dot pijul dot com).

Ah I created an account with sjmackenzie which was probably already registered with my github account. So maybe an error message saying that the username is already taken?

I use chromium with the github account login attempt.