Pijul

Cannot push to nest


#1

I cannot push anything to the nest. I’m on Windows 10 with OpenSSH client enabled. I’ve added my ssh key, but couldn’t push the signing key. I’m on pijul 0.10.0

When trying to push either a repo or the signing key, It constantly asks for a password although I’ve typed it in several times.

pijul_bug

pijul_bug2


#2

Did you check in your nest account that your signing key is available? (you can add it manually there if you can’t push it from the cli). I had the same issue and it was that.


#3

The signature key doesn’t show up, and there doesn’t appear to be any way to add it manually.

image


#4

Yes, sorry, you have to look for the ssh key, in the same page. Copy paste into the box the full content of $HOME/.pijulconfig/id_***.pub

(signing doesn’t show up in the nest currently, but it’s an unrelated issue)


#5

I’ve already uploaded the ssh key (I generated it in the same way the github docs shows, using rsa), I just haven’t the signature key.


#6

I don’t know, then. To me, the ssh key was forgotten by the nest in the last few days due to the move to pijul 0.10.
You need feedback from @pmeunier , he is the maintainer of the nest


#7

I uploaded the ssh key today, I also had to recreate my account. Anyways, Thanks for the help!


#8

Hi! I’ve tried to look at this in the last few days, without success because I can’t reproduce. Would you mind giving more details, possibly in a discussion on the Nest (in the nest or pijul repositories of user pijul_org)?


#9

Sorry it’s taken me so long to respond to this. I’ve been busy with Finals for College, among other things. I will do my best to provide all the information you will need, but I don’t know much about Rust, SSH, networking, Pijul itself, etc. Thanks for looking into it!


#10

I just seen on the blog that SSH agents for Windows weren’t supported yet. Is this perhaps the reason why it’s not working for me, since I’m using the new OpenSSH feature for Windows 10? Should I use the gen-keys thing from within pijul instead?


#11

I wasn’t aware of the “new OpenSSH feature for Windows”, Pijul doesn’t use OpenSSH precisely for the reason that at the time I wrote that part, OpenSSH didn’t exist on Windows!

Pijul is probably not looking for your keys at the correct location. Where should it look?


#12

The feature can be enabled in the Manage Optional Features part of the Settings app. However, I don’t know if it’s Insider builds only or if it’s released with the latest update of Windows 10. It has the ssh-agent, and the default directory for the ssh keys is in the folder “.ssh” (dot-ssh) under the Windows User’s folder (so mine would be “C:\Users\krixa\.ssh”).


#13

Thanks!
Do you happen to know how the SSH agent works? On Unix, it uses unix sockets, but there are no such things on Windows.


#14

I don’t know how it works, but here’s the repo for OpenSSH for Windows. Perhaps this will help: https://github.com/PowerShell/Win32-OpenSSH


#15

Thanks. I guess this is the kind of stuff I should try out soon on my Windows.
@lthms: we probably want this in Pijul 0.11.


#16

I am having the same issue on macOS Sierra. Pijul asks for my Nest password even when I uploaded my public SSH and also set up SSH to use my private key with the nest.pijul.com host :thinking:


#17

@tae can you give more detail? What type is your key? Is it encrypted?


#18

Edit: I received the email to recover my password and the key generated by Pijul works

Sure, sorry I didn’t it before. The key is in RSA format and is encrypted. The password is stored on the OS keychain.

I tried to generate a key with Pijul itself an I noticed that it is Ed25519 without password by default but I cannot try it: the Nest doesn’t allow me to log in and if I try to recover my password it responds with 404


#19

A bug related to encrypted rsa was fixed recently in thrussh. Could you try to find out which version of crate thrussh-Keys you have, possibly by reinstalling pijul?


#20

Mmm… I installed Pijul 0.11 using Nix and the unstable channel. Is that enough?