Pijul

Unable to sign to nest.pijul.com

Login: kvark

Clicking on “Sign In” results in no action. Clicking on the github icon gives me

Internal server error

1 Like

Hi! Sorry for the late reply, I’m not sure what’s going on, I just tested it with my own account (P-E-Meunier) and it worked. You do have a valid account though, maybe you should reset your password?

Also, I just saw that when you have an account (with email+password) and try to login with GitHub, with the same user name, you do indeed get “internal server error”. Let me fix this right away, thanks.

I have the same problem but when “Sing up”. I get Forbidden.

but refreshing the page solved the problem.

Have you tried to refresh the page?

Nothing works.
On the front page - https://nest.pijul.com/ - filling up the name/password and clicking “Sign In” does nothing, no response, no change.
If I click on “github” icon, I get “Forbidden” page. Refreshing or clicking on “Sign in” at the top changes nothing - still getting “Forbidden”.

@kvark: sorry to hear that, let me try to fix this right now. Can you go to https://nest.pijul.com/password_reset

@azzamsa: did you sign up with GitHub initially, or with a password?

Going into the account setting from the link in the email, I tried entering a different password in the “Password” field, followed by clicking “Update”. The form just refreshes with an empty password and no indication of a change. Same for changing the user picture.

Logging out from that session and trying to login normally results in the same symptoms: Forbidden.

Alright, I’m not sure what’s going on, but I’ve just deleted your account. You can start from scratch and report back.

Created an account. After I logged out, I can’t log in any more. Same symptoms.

This is expected, actually, it means your password was successfully changed (I agree the feedback could be better). I just tested it.

I think I’m able to log in now, manually at least. Somehow I got messed up the passwords.
Logging in with Github is still Forbidden though.

1 Like

Ok, thanks for reporting back, this is great news.
If you want to log in with GitHub, you need to “attach” your GitHub account from your account settings page, by clicking on the GitHub icon.

I definitely need to work on the feedback messages. It’s getting a bit late for today, but I’ll git it a shot tomorrow.

I sign up using Github. The page stuck at

https://nest.pijul.com/oauth/github?code=8305xxxx0522d2faxxxx&state=xwNWb7xxxBUALdA1JXXXX

and says Forbidden.

I just copy the URL above in the same page then hit enter (refresh). Problem solved.

1 Like

@azzamsa: thanks for reporting. I’ll investigate this. Even though the server is generally stable and is fully asynchronous, it sometimes get stuck for seemingly networky reasons. May I ask you where you are connecting from? (the server is in Europe).

Thanks a lot for maintaing Pijul.

my connections comes from Asia/Jakarta

1 Like