RepoCommander - first GUI for Pijul - help / volunteers needed


I’m Tomasz and I’ve just created first GUI for Pijul - RepoCommander. RepoCommander is a multi-platform (Linux/Win/macOS) wrapper for version control systems - Git and Pijul. So you have to have installed them first on your machine.

3 main functionalities for Pijul at the moment are:

  1. Status - you can easily see which files were modified
  2. Unified diff - see unified diff of current changes
  3. Move/copy - move changes between channels with just one click

More screenshots on official website

At the moment I’m looking for volunteers / testers who are willing to give it a try and provide some feedback - preferably on official website to avoid spamming here.

I hope this post doesn’t violate any code of conduct - if so please move it to proper category. Overall goal is to make Pijul more popular and user-friendly.



Wow! Was not expecting a working GUI for some time. Will download it and give it a try straight away!

Great work :slight_smile:

1 Like

I tried it the other day when you mentioned it on Zulip. I had a problem with scrolling in a Pijul repo whereas scrolling a Git repo was fine.
Today I tried the latest version and it didn’t run and no errors I could see. (Ubuntu 22.04 LTS)
I went to your forum site, but didn’t want to sign up for yet another place to chat. If you had open source, we could help and discuss on its repo…

1 Like

I’d be more than happy to help. Have you tried to use AppImage instead for Linux? Are there any messages in the terminal when you try to run it? Can you provide an example repository or screenshot where this could be observed? I was using pijul-manual for tests but it’s rather small - only ~63 entries. Whenever you enter a new directory 3 commands are executed:

pijul ls
pijul diff -us
pijul channel

so there is still of lot of places to hunt bug down.
In terms of source code it’s not intended to be open source but I’m happy to share more to find / fix this bug - please send me private message if you don’t want to reveal too much details here.

Edited thanks @joyously for sharing details. bug has been created and will be fixed in upcoming release.